Wizard: Duplicate User

Body

Symptom

A user successfully logs in to find themselves identified as another user entirely.

Cause

Duplicate usernames in the wizard_user table

Solution: Change the username of the user exhibiting the symptom to a unique username

Steps for the change:

1) Identify Wizard ID of the incorrectly behaving user account:

SELECT *
FROM WIZARD_USER
WHERE
lower(USERNAME) = '{current username - must be all lowercase}';

This will return two (or more) entries in the Wizard_User table and you must use the information in the table (Date of Birth, account creation date, etc) to determine which account is the one that is being reported as misbehaving and record the Wizard ID.


2) Validate the target username is not in use.
SELECT *
FROM WIZARD_USER
WHERE
lower(USERNAME) = '{new username - must be all lowercase}';


No records shown indicates the new username is not already in use.

3) Change the user's username to the new, unique, name.
UPDATE wizard_user
SET username='{new username - must be all lowercase}'
WHERE
ID={User's Wizard ID};


4) Verify the change was successful and the username is unique.

SELECT *
FROM WIZARD_USER
WHERE
lower(USERNAME) = '{new username - must be all lowercase}';


One record returned with the Wizard ID of the original user, username is unique and issue resolved.

5) Once verified, commit the change.

6) Inform the student or student's councilor of the new username.

 

Details

Details

Article ID: 1590
Created
Tue 5/20/14 3:12 PM
Modified
Fri 4/11/25 11:15 AM